神奇指标网
神奇指标网

大智慧东方财富通ddx指标公式_大智慧指标公式

浏览 147次浏览
标签: DDX
来源:神奇指标网 编辑:神奇指标网 发布日期:2024-01-10

以下是大智慧东方财富通ddx指标公式源码和截图


大智慧东方财富通ddx指标公式源码:

   万手:vol/10000,LINETHICK0;

   AA:=IF(CURRBARSCOUNT=1ANDPERIOD=5,VOL*240/FROMOPEN,DRAWNULL);

   预测:AA/10000;

   BB:=VOL/((HIGH-LOW)*2-Abs(CLOSE-OPEN));

   主动买:=IF(CLOSE>OPEN,BB*(HIGH-LOW),IF(CLOSE<OPEN,BB*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));

   主买:主动买/10000,COLORRED;

   主动卖:=IF(CLOSE>OPEN,0-BB*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-BB*(HIGH-LOW),0-VOL/2));

   主卖:-主动卖/10000,COLORGREEN;

   差额:(主动买+主动卖)/10000;

   stICKLINE(CLOSE=REF(CLOSE,1),0,VOL,3.5,0),COLORWHITE;

   STICKLINE(CLOSE>REF(CLOSE,1),0,VOL,3.5,0),COLORRED;

   STICKLINE(CLOSE<REF(CLOSE,1),0,VOL,3.5,0),COLORGREEN;

   STICKLINE(CURRBARSCOUNT=1ANDPERIOD=5,AA,1,3.5,0),COLOR00FFFF;

   STICKLINE(CURRBARSCOUNT=1ANDPERIOD=5,AA,1,3.2,0),COLOR007777;

   STICKLINE(CURRBARSCOUNT=1ANDPERIOD=5,AA,1,2.7,0),COLOR009999;

   STICKLINE(CURRBARSCOUNT=1ANDPERIOD=5,AA,1,2.1,0),COLOR00BBBB;

   STICKLINE(CURRBARSCOUNT=1ANDPERIOD=5,AA,1,1.5,0),COLOR00ddeE;

   STICKLINE(CURRBARSCOUNT=1ANDPERIOD=5,AA,1,0.9,0),COLOR66FFFF;

   STICKLINE(CURRBARSCOUNT=1ANDPERIOD=5,AA,1,0.2,0),COLORFFFFFF;

   STICKLINE(主动买>=0,VOL,-主动卖,3.2,0),COLOR000033;

   STICKLINE(主动买>=0,VOL,-主动卖,2.7,0),COLOR000066;

   STICKLINE(主动买>=0,VOL,-主动卖,2.1,0),COLOR000099;

   STICKLINE(主动买>=0,VOL,-主动卖,1.5,0),COLOR0000CC;

   STICKLINE(主动买>=0,VOL,-主动卖,0.9,0),COLOR0000FF;

   STICKLINE(主动买>=0,VOL,-主动卖,0.2,0),COLORCC66FF;

   STICKLINE(主动卖<=0,0,-主动卖,3.2,0),COLOR990000;

   STICKLINE(主动卖<=0,0,-主动卖,2.7,0),COLORCC0000;

   STICKLINE(主动卖<=0,0,-主动卖,2.1,0),COLORFF4400;

   STICKLINE(主动卖<=0,0,-主动卖,1.5,0),COLORFF8800;

   STICKLINE(主动卖<=0,0,-主动卖,0.9,0),COLORFFCC00;

   STICKLINE(主动卖<=0,0,-主动卖,0.2,0),COLORCYAN;

   币:IF(SAR(10,2,20)>=H,sar(10,2,20),DRAWNULL),CIRCLEDOT,COLORBLUE;

   股:IF(SAR(10,2,20)<=L,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLORRED;WJ:=(H+L+C)/3;

   V1:=IF(H=L,1,H-maX(O,C));

   V2:=IF(H=L,1,MAX(C,O)-WJ);

   V3:=IF(H=L,1,MIN(O,C)-L);

   V4:=IF(H=L,1,WJ-MIN(C,O));

   V5:=VOL/IF(H=L,4,H-L);

   V6:=(V1*V5);

   V7:=(V2*V5);

   V8:=(V3*V5);

   V9:=(V4*V5);

   买盘:=(V9+V8);

   卖盘:=(V6+V7);

   买卖差:=买盘-卖盘;

   ddx:=买卖差;

   DX:=MA(买卖差,5)*20;

   DDX1:SMA(DX,3,1),COLORFFFFFF;

   DDX2:SMA(DDX1,3,1),COLOR00FFFF;

   DDX3:(5*DDX2+4*REF(DDX2,1)+3*REF(DDX2,2)+2*REF(DDX2,3)+REF(DDX2,4))/15;

   N:=20;JJ:=(HIGH+LOW+CLOSE)/3;QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);

   QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));

   QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));

   QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));

   QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));

   DDX:((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,1000000,10000),COLOR00AAAA,LINETHICK;

   DX:=MA(DDX,5)*N;

   STICKLINE(DDX>0,0,DDX,3,0),COLOR000088;

   STICKLINE(DDX>0,0,DDX,2.5,0),COLOR0000AA;

   STICKLINE(DDX>0,0,DDX,1.5,0),COLOR0000CC;

   STICKLINE(DDX>0,0,DDX,1,0),COLOR0000EE;

   STICKLINE(DDX<0,0,DDX,3,0),COLOR008800;

   STICKLINE(DDX<0,0,DDX,2.5,0),COLOR00AA00;

   STICKLINE(DDX<0,0,DDX,1.5,0),COLOR00CC00;

   STICKLINE(DDX<0,0,DDX,1,0),COLOR00EE00;

   DDX1:SMA(DX,3,1),COLORFFFFFF;

   DDX2:SMA(DDX1,3,1),COLOR00FFFF;

   DDX3:EMA(DDX2,5),COLORFF00FF;

   VARA:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

   VARB:=SMA(VARA,3,1);

   VARC:=SMA(VARB,3,1);

   探索者:=EMA(3*VARB-2*VARC,3),COLORCYAN;

   趋势:=MA(探索者,3),COLORRED;

   主力:=EMA((CLOSE-MA(CLOSE,7))/MA(CLOSE,7)*480,2);

   散户:=EMA((CLOSE-MA(CLOSE,11))/MA(CLOSE,11)*480,7);

   DIF:=EMA(CLOSE,6)-EMA(CLOSE,13);

   DEA:=EMA(DIF,5);

   出击:CROSS(主力,-10)ORCROSS(主力,-2)ORCROSS(主力,0)ORCROSS(REF(主力,1),0)AND趋势>=REF(趋势,1)AND趋势<80AND散户>-35AND主力>REF(主力,1)ANDDIF>DEAAND(C-REF(OPEN,3))/REF(C,3)<0.1;

   预警:DDX>0ANDMA(V,5)>MA(MA(V,5),5)ANDCROSS(DDX1,DDX2),LINETHICK;

   天:=COUNT(DDX>0,5),COLORRED;

   DRAWTEXT(预警,DDX*1.06,'★'),LINETHICK3,COLOR00FFFF;

   AA:=vol/((HIGH-LOW)*2-Abs(CLOSE-OPEN));

   买量:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));

   卖量:=IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-AA*(HIGH-LOW),0-VOL/2));

   大单动向:买量+卖量,color3d;

   MA1:MA(大单动向,3),COLORRED;

   MA2:MA(大单动向,5),COLORGREEN;

   MA3:MA(大单动向,10),COLORYELLOW;

   FILLRGN(MA2,MA1,MA2<MA1,rgb(180,50,0),MA2>MA1,rgb(0,50,180)),layer5;

   FILLRGN(MA3,MA2,MA3<MA2,rgb(200,0,100),MA3>MA2,rgb(0,100,100)),layer5;

   1,DOTLINE,colorFF7676,PRECIS0;

   DRAWTEXTREL(5,10,'东方财富通ddx-L2'),COLORyellow;




大智慧东方财富通ddx指标公式截图

神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论