神奇指标网
神奇指标网

通达信日周月KDJ指标 三周期合一必然孕育大牛股 说明 源码

浏览 4830次浏览 来源:通达信公式 编辑:神奇指标网 发布日期:2022-10-12




以下是通达信日周月KDJ指标 三周期合一必然孕育大牛股 说明 源码




日周月KDJ指标 三周期合一必然孕育大牛股 说明 源码



炒股看一下周、月线十分有必要,很多时候,周、月线已经死叉下行,中长线趋势走坏,但日线偏偏发出金叉,K线也走好,量价配合也好,而此时介入,多数情况下就是中、短期头部。

1、KDJ日、周、月线低位金叉——低位启动,坚决买进。

2、KDJ日线金叉,周、月线高位运行——面临调整,不宜介入。

3、KDJ日线金叉,周线KDJ向上,月线KDJ向下——反弹行情,少量参与。

4、KDJ日线金叉,周线KDJ向下,月线KDJ向上——主力洗盘,周线反转

5、KDJ日、周、月线高位运行———风险在即,不宜介入。

6、KDJ日线高位运行,周、月线低位运行——短线回调,二次金叉。

股票不是天天可做的,也没必要天天做,累的人不会赚钱,会赚钱的人不累。不是机会不动手,动手就抓大机会,一出手就赢:月KDJ在低位,周KDJ在10以下形成金叉就是大机会,巨大的获利机会来临,实战中必须敢于捕捉,果断进场,九生一死。

一、月KDJ的J值在20以下,周KDJ的J值在10以下时个股或大盘孕育着巨大的历史性暴涨的赢利机会,我们操作时不要为走势的悲观绝望的心情所左右,敢于领先一步进场参战,要为人之所不敢为。J值越低机会大越大,一旦J的运动方向由下转向上时,机会即降临了。月KDJ在低位孕育的是大机会,周KDJ在低位孕育的是中级情,日KDJ在低位只有短线小行情。

二、相反月KDJ,周KDJ在高位J值90以上时孕育着巨大暴跌风险,此时不要为走势的茑歌燕舞人气鼎沸疯狂所迷惑,必须敢于先人一急流勇退,为人之所不愿为。J值越高风险越大,一旦J值由上向下,死亡的恶魔现身。当月KDJ在高位意味着大级别的调整,周KDJ在高位意味着中级别的调整,日KDJ在高位意味着小级别的调整。(只要你是被套则肯定是月线或周线出了问题,绝对没有例外)

三、(1)日KDJ低位金叉只有短线机会。(此时周,月KDJ在高位死叉向下)不参与操作,只欣赏庄家表演。2.(此时周KDJ方向朝上,而月KDJ向下死叉向下),则只有中短线行情。3.(此时月KDJ金叉向上,而周KDJ死叉向下),则该股进入中级调整。4.(此时月KDJ高位死叉向下),周,日KDJ都在低位金叉向上则反弹力度较大。

四、而此时月、周、日KDJ所有指标在低位全部金叉共振向上发散攻击是千载难逢的巨大的历史性买进的机会,所有资金全线进场重拳参与操作敢于赢大钱。

五、月KDJ在低位向上形成金叉就是多头行情,做股票就是做多头行情,只要等周,日KDJ形成金叉就是买进的机会。相反月KDJ,周KDJ在高位孕育着巨大暴跌风险,切记,切记。

六、一般在月,周KDJ低位J值在10以下买进股票持有3--5个月获利30%以上是没什么问题的,基本上可以说是100%的。



副图源码




月K:"KDJ.K"(89,3,3),COLOR00FF00;

月D:"KDJ.D"(89,3,3),COLOR00FF00,LINETHICK2;

周K:"KDJ.K"(27,3,3),COLORRED;

周D:"KDJ.D"(27,3,3),COLORRED,LINETHICK2;

日K:"KD.K"(5,3,3),COLORWHITE;

日D:"KD.D"(5,3,3),COLORWHITE,LINETHICK2;

日金叉:IF(CROSS(日K,日D),50,0),COLORFFFFFF;

DRAWTEXT(日金叉,50,'日叉'),COLORFFFFFF;

周金叉:IF(CROSS(周K,周D),30,0),COLORRED;

DRAWTEXT(周金叉,30,'周叉'),COLORRED;

月金叉:IF(CROSS(月K,月D),20,0),COLOR0080FF;

DRAWTEXT(月金叉,20,'月叉'),COLORYELLOW;

{KD在30以下多次金叉}

JM:=CROSS("KDJ.K"(5,3,3),"KDJ.D"(5,3,3));

JMCOUNT:=COUNT(JM,BARSLAST("KDJ.D"(5,3,3)>=30));

JMTJ:=28*("KDJ.D"(5,3,3)<30 AND COUNT(JMCOUNT=1,21)=1);

DRAWTEXT (JMTJ,70,'①'),COLORWHITE;

JMTJ2:=28*("KDJ.D"(5,3,3)<30 AND COUNT(JMCOUNT=2,21)=1);

DRAWTEXT (JMTJ2,70,'②'),COLORYELLOW;

JMTJ3:=28*("KDJ.D"(5,3,3)<30 AND COUNT(JMCOUNT=3,21)=1);

DRAWTEXT (JMTJ3,70,'③'),COLORYELLOW;

JMTJ4:=28*("KDJ.D"(5,3,3)<30 AND COUNT(JMCOUNT=4,21)=1);

DRAWTEXT (JMTJ4,70,'④'),COLORYELLOW;

JMTJ5:=28*("KDJ.D"(5,3,3)<30 AND COUNT(JMCOUNT=5,21)=1);

DRAWTEXT (JMTJ5,70,'⑤'),COLORYELLOW;

0,COLORYELLOW;

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA);

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);

MACD底背离:STICKLINE(FILTER(B1>0,5),0,0.75,3,0),COLORGREEN;

DRAWTEXT(FILTER(B1>0,5),0.57,'MACD底背离'),COLORGREEN;

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

A2:=BARSLAST(REF(CROSS(K,D),1));

B2:=REF(C,A2+1)>C AND REF(K,A2+1)<K AND CROSS(K,D);

KDJ底背离:STICKLINE(FILTER(B2>0,5),0,1,3,0),COLORYELLOW;

DRAWTEXT(FILTER(B2>0,5),0.80,'KDJ底背离'),COLORYELLOW;

LC :=REF(CLOSE,1);

RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;

RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;

A3:=BARSLAST(REF(CROSS(RSI1,RSI2),1));

B3:=REF(C,A3+1)>C AND REF(RSI1,A3+1)<RSI1 AND CROSS(RSI1,RSI2);

RSI底背离:STICKLINE(FILTER(B3>0,5),0,0.5,3,0),COLORWHITE;

DRAWTEXT(FILTER(B3>0,5),0.25,'RSI底背离'),COLORWHITE;

2,COLORRED;

C1:=BARSLAST(REF(CROSS(DEA,DIFF),1));

D1:=REF(C,C1+1)<C AND REF(DIFF,C1+1)>DIFF AND CROSS(DEA,DIFF);

MACD顶背离:STICKLINE(FILTER(D1>0,5),2,1.25,3,0),COLOR0066FF;

DRAWTEXT(FILTER(D1>0,5),1.47,'MACD顶背离'),COLOR0066FF;

C2:=BARSLAST(REF(CROSS(D,K),1));D2:=REF(C,C2+1)<C AND REF(K,C2+1)>K AND CROSS(D,K);

KDJ顶背离:STICKLINE(FILTER(D2>0,5),2,1,3,0),COLORRED;

DRAWTEXT(FILTER(D2>0,5),1.2,'KDJ顶背离'),COLORRED;

C3:=BARSLAST(REF(CROSS(RSI2,RSI1),1));

D3:=REF(C,C3+1)<C AND REF(RSI1,C3+1)>RSI1 AND CROSS(RSI2,RSI1);

RSI顶背离:STICKLINE(FILTER(D3>0,5),2,1.5,3,0),COLORFF00FF;

DRAWTEXT(FILTER(D3>0,5),1.75,'RSI顶背离'),COLORFF00FF;

0,COLORFFA2AF;

20,COLORFFA2AF,POINTDOT;

50,COLORFFA2AF;

80,COLORFFA2AF,POINTDOT;

100,COLORFFA2AF;



指标源码(日,周,月同时出现)金叉选股公式:




月K:="KDJ.K"(89,3,3),COLOR00FF00;

月D:="KDJ.D"(89,3,3),COLOR00FF00,LINETHICK2;

周K:="KDJ.K"(27,3,3),COLORRED;

周D:="KDJ.D"(27,3,3),COLORRED,LINETHICK2;

日K:="KD.K"(5,3,3),COLORWHITE;

日D:="KD.D"(5,3,3),COLORWHITE,LINETHICK2;

日金叉:=IF(CROSS(日K,日D),50,0),COLORFFFFFF;

周金叉:=IF(CROSS(周K,周D),30,0),COLORRED;

月金叉:=IF(CROSS(月K,月D),20,0),COLOR0080FF;

月金叉 AND 周金叉 AND KDJ.D<30;



日周月KDJ指标 三周期合一必然孕育大牛股 说明 源码



神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论